Internal draft links

#1

Hi,
I dont know if this is a real issue of more a feature request.
I create a Review Note with a Script and Link all the note titles with the desired permalinks e.g. „title
When I want to open the draft „title“ of course in link mode, I tap on the title and I‘ll always see the Window in the screenshot attached. Is there any better way to do this?

Another confusing thing is that I have to tap on the link when I use the iPad to Open the popup. Tapping on the title does not work.

#2

If I tap such an intra-Drafts link, it immediately opens for me (on my iPhone 8+). If I force touch, I get the same pop-up that you are seeing.

#3

I can’t force touch on the ttitle - iPhone XS Max

#4

Just tried this with a link to a document in DEVONthink. Tapping goes straight to the document, force touch produces the pop up.

#5

@agiletortoise can you please clarify this?

#6

I’m not sure what I’m clarifying. If you tap on a to another draft link in link mode, it opens. If you force touch (or tap and hold on non-force touch devices), it opens the options menu you are displaying. Link mode makes URLs tappable, the title should not be tappable.

#7

That Not the case for me.
It does Not matter if i use the iPad or iPhone - i can tap on the internal draft link, but it just Shows the menu. It Never Directly opens the draft.
Force touch is not possible, it sometimes highlights some text but Never shows the menu.
I‘d Expert that in link Mode a tap on the link will directly jump to the draft and a Force touch would open the menu.

Im Running the newest draft versions on iPhone XS Max and iPad 2018

#8

Just tried this on my ipad so no force touch. Works exactly as described by Greg, very strange.

#9

Thats what i‘m talking about. Its not the same behaviour on mi devices.
Is this depending on some possible Settings?

#10

What behavior do you get in other apps that have links, like in a Mail message, or Notes app note? There’s no Drafts setting related to this…it would seem like it’s a system level thing.

#11

I sent the exact same draft as Markdown Mail to myself.
The First Time I want to Open the Link from the screenshot it asks ne for permissions that Mail Can Open the draft App.
From the Second Time on it instantly opens the draft. No question or other system dialog.

And when i Force Touch on the Link the Dialog from my screenshot opens in Mail