Go to end of draft?

I was regularly using one of the “go to end” actions in the directory. With the latest update, neither seems to work any more (they just do nothing.) Any ideas or suggestions or replacements? (I’m not very fluent in JS, so I can’t see what’s going wrong.) This is pretty annoying, since I use “go to end” extensively to add to an existing draft without having to scroll to the end first.

Replacements shouldn’t be necessary. Nothing fundamental enough to affect that should have changed for you.

A few things to try.

  1. Force close Drafts, reopen and retry.
  2. Reboot and retry.

If that doesn’t work, can you post a link to the action you are using so that others can review and test it?

In practice, this action I whipped up works for me on the latest version. It utilises a single two line JavaScript step.

editor.setSelectedRange(editor.getText().length, 0);

Thanks for this. Neither of the two things to try worked, but your action did - yay! The two previous actions that worked before the latest update but since fail (for me, at least, on four different iOS devices) are “Go to end of draft“ and “Go to end of draft A4D” in the Drafts directory.

Both of those actions use setTextInRange()to optionally modify the loaded draft’s end, but don’t seem to actively set the selection, which is what determines where the cursor is placed.

Glad my alternative helped. What it won’t do like those others is append a new line at the end if one is not present, but honestly, that’s something a little different than just jumping to the end of a draft.