Evernote ENML actions crash now


#1

My Evernote ENML actions, which formerly worked fine, now fail if they contain [[draft]] or [[body]].


#2

Mostly likely you have some content in your draft that is not valid ENML. If the Evernote action step is set to ENML, the template must output completely valid fully formed ENML or Evernote will reject it. Typically ENML would only be used in advanced cases where you are already contracting and validating the ENML content in a script or similar.

Could you post an example of the action configuration you are using?

And when you say “crash” do you mean Drafts is literally crashing, or the action is not working?


#3

It’s a one-step action that has worked as expected for years. The template is just this:

<en-todo/> [[title]] on [[date]]
<br/><br/>
[[body]]
<br/><br/>
<hr/>

If I remove [[body]] it works as it always did. Adding [[draft]] also causes it to fail. Drafts doesn’t crash. I just get the red “failed action” notification and the log says “ENML for note is invalid”.

Upon further testing, I see that it’s failing because there was a & in the draft body. Removing it allowed the action to work properly. And I was able to get it to work with the & included by adding %%:

%%[[body]]%% works.

Thanks for the response and for the awesome app!


#4

Great! Glad it’s sorted out.