Drafts imports text when files opened in Finder (unwanted behaviour)

mac

#1

I’ve been creating files using iOS Drafts and saving them to the iCloud Drafts folder as plain text files. Now when I open these files from the desktop they are imported into Drafts on macOS rather than opening in my default text editor.

I guess this is something to do with iOS sandboxing, and I also know that I can use the contextual menu to open in whatever app I like, but I would prefer not to have to remember to do this, especially as these are plain text files.

I’ve tried changing the “Open with…” setting on these files, but this just created an error next time the file was opened, so I had to change it back. I also noticed that although I initially changed this setting (to BBEdit) the pop-up remained showing as set to Drafts.

I’m using Drafts 5.5.1 (5.5.1.2) on macOS 10.13.6 (17G4015)


#2

I’ve seen this to. I agree that it’s probably a sandboxing issue. It also affects other Apps.

I get round the issue by using a simple Keyboard Maestro hotkey macro to open the files in my editor of choice.

Dave


#3

I’ve not noticed it before, but I’ve just tested with iA Writer and you’re right, it does the same. I suppose I’ve missed this feature because I generally avoid saving files into their application folders on iCloud, preferring to use my own folder hierarchy.


#4

It’s frustrating. I understand, and like, the idea of sandboxing but I think there should be a division between iCloud data stored by Apps, which should be sandboxed, and files stored to iCloud Drive, which shouldn’t.

I think there should be an access warning like contacts, calendar etc (i.e. “This app would like to access your entire iCloud Drive”) but beyond that if I’m choosing to write a file it’s probably because I want to do something with it outside the originating app and I should be allowed to do so easily.


#5

Using the ”Save to File” action in the Basic- list will save the file with macOS Texteditor as the default. You can then open this file with your preferred editor.


#6

This is iCloud Drive behavior. For files within an app’s container folder, that app is treated as the default for the files regardless of OS settings. It is a bit annoying, agreed, but not something the app has any control over.


#7

Hi @Gul-ipad, I know I can save a file outside the Drafts folder, but then Drafts can’t append to the file because it’s outside the Drafts folder.


#8

In which case, I’m wondering if there should be some way to intercept the file before it gets imported to Draft, such that it gets opened by Drafts but not actually imported until some additional user action, perhaps into a temporary window with an import button?

Or some clever method to ensure that the file is only imported once. At present, each attempt to open the file in Finder imports a new copy.