Drafts App Reinstallation Issue on Apple Watch Gen 3

I recently performed a complete reset and fresh installation on my Apple Watch. However, I’ve encountered a problem while trying to reinstall the Drafts app. Despite multiple restarts of both my watch and phone, the issue persists.

Interestingly, I’ve been able to install other apps without any hitches. The problem seems to be specific to the Drafts app. I tried to install the app from the Watch app on the iPhone as well as the App Store on the Watch. For context, I’m currently using Watch OS 8 on a Generation 3 Apple Watch.

Does anyone have insights into what might be causing this issue? Any suggestions or solutions would be greatly appreciated. Thanks in advance!

What is the issue? You mentioned several times that there is an issue, but never what the issue actually is :confused:

The app doesn’t complete installation and process keeps getting interrupted.

Have you reinstalled on the phone yet? That’s the next thing I’d try. I’ve seen a few cases over the years there iOS just didn’t unpack and install the app properly on the phone and it creates issues trying to install on the watch.

Yes, it’s installed on my phone. I tried toggling the automatic install but didn’t help.

I asked if you had reinstalled. e.g. removed and re-installed the app from the iPhone.

Sorry, I hurriedly read the last message. Yes I did reinstall the app on my iPhone. I’m resetting the watch again to see if it fixes the issue.

Same behavior.

From Watch App Store, the error is “Unable to complete request“.

From iOS watch app, it quits the Drafts app installation process after 5-10 seconds.

Seems I jinxed it by resetting the watch. I can only think about restoring from an earlier backup. No other option comes to mind… :frowning: