Drafts 28 Released - Ready for new iOS/macOS, Folder Bookmarks, and More

great, thanks so much! Now I can finally ditch my over-complicated workaround of calling an action via URL Scheme which sets all those :slight_smile:

Can’t wait for iOS 15 to play around with Shortcuts.

1 Like

I just spent 5 minutes wondering why my links won’t open via cmd + click before I realized it’s only Drafts wikilinks :sweat_smile:

Please implement cmd + click to open a link for all types of links, would be really useful (and also in line with the behavior of other markdown apps) :pray:

1 Like

Example? This behavior is for links to other drafts, and should work with either [[wiki-style]] links, and drafts://open?... style URLs (when activated in link mode).

Non-drafts links (e.g. http) already open in browser.

Oh sorry, that wasn’t phrased very clearly by me. I was meant this feature request I made from a while back to open links in normal mode (i.e. not link mode) by using cmd + click.

My wish above was basically only a re-iteration of that feature request.

So I originally thought it was a problem with my Search Actions action but actually it would appear that it’s actually the bluetooth keyboard command ⌘ + / is no longer functioning with the update.

I can do a formal ticket if you’d like.

Drafts Version: 28.0.40
OS Version: iOS 15.0
Device: iPhone 12 Pro Max
Pro Licensed: Yes

Thanks for this update - the Folder Bookmark function in particular should solve something I’ve been trying to do neatly for a while - export to Obsidian. But, I’m getting an error on my Mac with the Bookmark. I’m using the name of the bookmark (but have tried the folder path as well) and I’m getting an error:

Script Error: TypeError: Argument does not match Objective-C Class

I’m using code like:


fmBookmark = FileManager.createForBookmark("Obsidian")

I’ve got it to work with the File action step - but for some reason, I always like to do these things through scripts.

I’m on the latest public beta of Monterey if that makes a difference.

I think there was a misleading example in the FileManager docs, I’ve fixed that. The function takes a Bookmark object. Like:

// find or create a named Bookmark
let bookmark = Bookmark.findOrCreate("My-Folder");
let fm = FileManager.createForBookmark(bookmark);

What are you expecting ⌘-/ to do? Don’t believe that is a keyboard shortcut Drafts defines. Did you have it attached to an action?

1 Like

Yup! I had it attached to the TAD-Search Actions action, but I can’t seem to get it to respond at all (attaching it to other actions to test,) along with a few others I’ve discovered in the past few hours:

  • ^ + -
  • Option + /

Getting fairly worried - I sent you, Tim, and Snell a Tweet reply thread about this - because I suspect it’s not your error but an omission of the iPhone from whatever’s changed with “Universal Keyboard Support” (ironically, given that title.)

I’m not sure what you are seeing, are you on iOS 14 or iOS 15 beta? I only tested on the 15 beta, but can successfully bind Drafts actions to those shortcuts and they work from a bluetooth keyboard connected to an iPhone.

1 Like

You’re correct! I’m running the Release Candidate of 15 on a Dev profile, but was able to get the shortcuts to respond again after restarting my handset. Sorry about that…

Though on the subject, since iPhone users do not have the benefit of the keyboard shortcut guide/panel that appears when holding on iPad, is there any way you could publish the contents of that panel for Drafts in a table format?

I will literally make it for you if you send me screenshots.

For action assignments there are some Thoughtasylum library actions that export them in slightly different list formats into new drafts.

2 Likes

The built-in commands are really only what is in the File/Edit/View menus (see below).

The rest belong to actions and depend on what you have installed/configured. Were you aware that you can enable display of keyboard shortcuts in the action list in the (...) list options?


1 Like

Yes! We’ve actually had that conversation before but I appreciate your suggestions.

That screenshot is precisely what I need thank you so much.

(I’ve been using iPads on display at my local best buy to grab screenshots but obviously I can’t install Drafts on those.)

Actually… Looks like ‘⌘ + ,` no longer opens Settings. (This is why having the full list would be handy.)

Edit: ⌘ + Option + , no longer opens the Editing menu.

Thanks - that works now. And works very quickly!

I’m still using Series 3 Watch. When I changed to the Capture complication (the one with the mic icon), the complication always revert back to the Drafts icon when I switch between Watch faces. Pressing the complication launches Drafts in the capture mode. It’s just strange that the mic icon did not stay still. Watch OS 7.6.2 (18U80) here.

Is it expected not to find the Drafts complications anymore in the app? I only see 4 complications:

It should update to mic icon…sometimes watchOS take a little while to catch up with refreshing for changes.

The preference keyboard shortcuts were overlooked, they will be re-added in next update.

1 Like