Draft not Found Error on Apple Watch Only

I have a shortcut that uses the get draft by uuid feature. Works all the time on my phone. Used to work on my Apple Watch as well. Lately, it will error out with “Invalid Draft: Draft not found” when I try to run it via watch. Still works on the phone.

Oddly, I have another shortcut that uses the same get draft by uuid and even uses the same uuid - and it runs perfectly on watch or phone every time.

Can’t figure out how to fix the one that works on phone but not Apple Watch.

Has anyone seen this before? Or have a tip for trying to fix it?

1 Like

Welcome @bnkgriffith (as it says you a new here).

Can you post the code?

Thanks Martin. As it is a shortcut, I am unsure how to post the code. Fortunately it is short and fits within 1 screen, so I’ve attached a screenshot.

I tried:

  1. duplicating the shortcut
  2. attaching the shortcut to a new draft (new UUID)
  3. adding/removing the shortcut to the apple watch

It is so strange that this used to work and now doesn’t.

Anyone who deploys the string “xyzzy” is doubly welcome here. :slight_smile:

I should ask what “Lately” means here. Also whether you get a message like “has to run on your phone”. (I’m not sure third-party (donated) actions in a Shortcut can even run on the watch.)

Note: This is not just of academic interest to me; I’d love to run things, especially Drafts (inter) actions from my Watch.

  1. Have you tried rebooting both devices?
  2. Have you tried switching the UUID to a different draft; for testing purposes.

I just played around with this a little and as far as I can tell it is a Shortcuts issue.

I can reproduce similar failures on Watch retrieving data from other apps as well, even though the same shortcuts work fine on the phone.

I’ll try to come up with some more definitely information and report it to Apple this week.

I setup a basic shortcut that gets a draft and displays it with “Show Alert”, and tried getting Sheets from Ulysses and a few other similar steps - and they all work perfectly on the phone, but display blank data on the Watch.

1 Like

I’ve always thought Shortcuts on the Watch to be a mess. You never know whether it’s going to stay running on the watch. I wonder if this problem is one where the watch doesn’t recognise it can’t run an action until it’s too late.

For the most part, the Watch cannot run Shortcuts. It triggers shortcuts that actually run on the phone. I have also found this to be somewhat fragile, though they have made many improvements. Seems like something recently broke, however.

1 Like

Amen, brother. :frowning: :slight_smile:

Wow! Y’all have really taken the ball and run with this. Thanks!

I’ll just keep running it from the phone and hope for a fix from Apple. I appreciate the research & testing & communication.