Cannot edit Drafts widgets

I am not able to edit any of the Drafts widgets in iOS 14.0.1 (new iPhone SE). I have the same problem with my iPad. After I add a Drafts widget, I see a gray box (or boxes depending on what widget I add). When I long press the Drafts widget, I get an option to “Edit Widget”, but when I press that, nothing happens. I have the latest version of Drafts. The gray widget will simply open Drafts when I touch it.

Have you tried removing and reinstalling the app, or restarting your device?

Yes, I tried both of those suggestions on both devices, but the problem remains. I may just wait to see if a round or two of the bug fix updates of Drafts and iOS does the trick. For me, the widget seems nice but not essential at the moment. Though I remain curious, as all my other widgets can be edited, and it seems other people can edit their Drafts widgets.

You aren’t the only one seeing this behavior, and I’m pretty sure it’s related to some crash logs I’m seeing - but the crash is not in Drafts code, but deep in the bowels of the Widget APIs. Pretty hard to do anything about if I can’t reproduce, but I’m still tracking it.

1 Like

Perhaps tonight’s update to 14.01 will resolve the issue?

1 Like

Updated to iOS 14.0.1 and still no change on my end.

If you are interested, I’d love to hear if it still happens in the Drafts beta ( It’s now being built on the iOS 14.2b SDKs and I’m curious if that helps.